Services Outages - Microsoft Azure

Incident Report for HSO Connect UK

Resolved

This incident is now resolved, Microsoft are not reporting any further issues detected at this time.
Posted Oct 09, 2025 - 16:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 12:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 09, 2025 - 12:20 UTC

Update

For live updates from Microsoft Azure please visit their status page at: https://azure.status.microsoft/en-gb/status
Posted Oct 09, 2025 - 10:16 UTC

Identified

Microsoft Azure are a third party provider who are currently experiencing a major outage. This is not a problem with Exact or Dentally, from our team we are unable to resolve this issue currently. We will update this page as we learn more information. You do not need to notify us if you are affected.

We apologise for the disruption and appreciate your patience.

For live updates from Microsoft Azure please visit their status page at: https://azure.status.microsoft/en-gb/status
Posted Oct 09, 2025 - 08:52 UTC
This incident affected: API gateway to EXACT databases, HSO Connect - Login, HSOne Payment services, and Online booking recall links (SMS and email).